<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Caribbeantales International Film Festival: The Legacy Edition &laquo;  CaribPR Wire</title>
<meta name="description" content="Caribbeantales International Film Festival: The Legacy Edition" />

	
<script type="text/javascript"> var _gaq = _gaq || []; _gaq.push(['_setAccount', 'UA-45573729-1']); _gaq.push(['_trackPageview']); (function() { var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'https://www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); })(); </script>

	
	<meta name="Keywords" content="	CaribbeanTales, Caribbeantales International Film Festival, film festivals, toronto film fests,  Caribbean-American, Caribbean Press Release, Marketing, Press Release Distribution, Media houses, journalists, Public Relations, Caribbean Community, West Indian release, West Indies media" />
<meta name="google-site-verification" content="tg2NcO3P1CgkRaypQlX-oufH0wFK6zCq73_ffY4spAc" />
<meta name="y_key" content="a480b0b38bd45a9a"/>
<link rel="stylesheet" href="http://caribpr.com/wp-content/themes/Caribpr2/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="CaribPR Wire RSS Feed" href="http://caribpr.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="CaribPR Wire Atom Feed" href="http://caribpr.com/feed/atom/" />
<link rel="pingback" href="http://caribpr.com/xmlrpc.php" />
<link rel="Shortcut Icon" href="http://caribpr.com/wp-content/themes/Caribpr2/images/caribpr.png" type="image/x-icon" />
<!-- <link rel="shortcut icon" href="http://caribpr.com/wp-content/themes/Caribpr2/favicon.ico" /> --> 

<script src="/js/jquery-1.3.1.min.js" type="text/javascript"/>
				<script type="text/javascript"> 
				$(document).ready(function() {
					  $('#n1').hide();
					  $('#n2').hide();
					  $('#n3').hide();
					  $('#n4').hide();
					  $('#n5').hide();
					  $('#n6').hide();
					}); 
				</script>
				
				<script type="text/javascript">
				
				$(document).ready(function() {
				   $('#togglen1').click(function(){
					 $('div#n1').toggle();
				   });
				   $('#togglen2').click(function(){
					 $('div#n2').toggle();
				   });
				   $('#togglen3').click(function(){
					 $('div#n3').toggle();
				   });
				   $('#togglen4').click(function(){
					 $('ul#n4').toggle();
				   });
				   $('#togglen5').click(function(){
					 $('div#n5').toggle();
				   });
				   $('#togglen6').click(function(){
					 $('div#n6').toggle();
				   });
				 });
				 
				 </script>

<script src="/js/blankwin.js" type="text/javascript"/>


<script type="text/javascript" src="/wp-content/ckeditor/ckeditor.js"></script>

<!--[if IE 6]>
<style type="text/css">
.comment-form{margin-bottom: -3px}
</style>
<![endif]-->

<link rel='stylesheet' id='wpsc-theme-css-css'  href='http://caribpr.com/wp-content/plugins/wp-e-commerce/themes/marketplace/marketplace.css?ver=3.7.41' type='text/css' media='all' />
<link rel='stylesheet' id='wpsc-theme-css-compatibility-css'  href='http://caribpr.com/wp-content/plugins/wp-e-commerce/themes/compatibility.css?ver=3.7.41' type='text/css' media='all' />
<link rel='stylesheet' id='wpsc-product-rater-css'  href='http://caribpr.com/wp-content/plugins/wp-e-commerce/js/product_rater.css?ver=3.7.41' type='text/css' media='all' />
<link rel='stylesheet' id='wp-e-commerce-dynamic-css'  href='http://caribpr.com/index.php?wpsc_user_dynamic_css=true&#038;category=1&#038;ver=3.7.41' type='text/css' media='all' />
<link rel='stylesheet' id='wpsc-thickbox-css'  href='http://caribpr.com/wp-content/plugins/wp-e-commerce/js/thickbox.css?ver=3.7.41' type='text/css' media='all' />
<link rel='stylesheet' id='A2A_SHARE_SAVE-css'  href='http://caribpr.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.6' type='text/css' media='' />
<script type='text/javascript' src='http://caribpr.com/wp-includes/js/jquery/jquery.js?ver=1.3.2'></script>
<script type='text/javascript' src='http://caribpr.com/wp-content/plugins/wp-e-commerce/js/wp-e-commerce.js?ver=3.741'></script>
<script type='text/javascript' src='http://caribpr.com/wp-content/plugins/wp-e-commerce/js/ajax.js?ver=3.741'></script>
<script type='text/javascript' src='http://caribpr.com/index.php?wpsc_user_dynamic_js=true&#038;ver=3.7.41'></script>
<script type='text/javascript' src='http://caribpr.com/wp-content/plugins/wp-e-commerce/wpsc-admin/js/jquery.livequery.js?ver=1.0.3'></script>
<script type='text/javascript' src='http://caribpr.com/wp-content/plugins/wp-e-commerce/js/user.js?ver=3.741'></script>
<script type='text/javascript' src='http://caribpr.com/wp-content/plugins/wp-e-commerce/js/thickbox.js?ver=Instinct_e-commerce'></script>
<script type='text/javascript' src='http://caribpr.com/wp-includes/js/comment-reply.js?ver=20090102'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://caribpr.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://caribpr.com/wp-includes/wlwmanifest.xml" /> 
<link rel='index' title='CaribPR Wire' href='http://caribpr.com' />
<link rel='start' title='SUPER LOTTO PRESS RELEASE &#8211; Something BIG is coming!!!' href='http://caribpr.com/super-lotto-press-release-something-big-is-coming/' />
<link rel='prev' title='Oxitec&#8217;s Friendly™ Aedes Mosquito Receives Positive Evaluation for European Standard in relation to Human Health and the Environment' href='http://caribpr.com/oxitecs-friendly%e2%84%a2-aedes-mosquito-receives-positive-evaluation-for-european-standard-in-relation-to-human-health-and-the-environment/' />
<link rel='next' title='Royalton Luxury Resorts expands All-in Luxury® with Royalton Fit™, its professional fitness and wellness program' href='http://caribpr.com/royalton-luxury-resorts-expands-all-in-luxury%c2%ae-with-royalton-fit%e2%84%a2-its-professional-fitness-and-wellness-program/' />
<meta name="generator" content="WordPress 2.8.6" />

<script type="text/javascript"><!--
var a2a_config=a2a_config||{},wpa2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='http://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);wpa2a.script_load=function(){};},script_onready:function(){if(a2a.type=='page'){wpa2a.script_ready=true;if(wpa2a.html_done)wpa2a.init();}},init:function(){for(var i=0,el,target,targets=wpa2a.targets,length=targets.length;i<length;i++){el=document.getElementById('wpa2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}wpa2a.done=true;}wpa2a.targets=[];}};a2a_config.tracking_callback=['ready',wpa2a.script_onready];
//--></script>
   <link rel="stylesheet" href="http://caribpr.com/wp-content/plugins/tdo-mini-forms/tdomf-style-form.css" type="text/css" media="screen" />
   <link rel='alternate' type='application/rss+xml' title='CaribPR Wire Product List RSS' href='http://caribpr.com/index.php?rss=true&amp;action=product_list'/></head>
<body id="top">
<div id="container">
    <div id="wrapper">

        <div id="header">
            <div id="logo">
                <!-- Your Logo image - max-width: 200px -->
                <!-- USAGE:
                	1-create your own logo and save it as logo.jpg in the folder "images" in your theme folder.
                	2-uncomment code below:
                <a class="logo" href="http://caribpr.com/" title="Back Home"></a>
                -->
        	    <h1><a href="http://caribpr.com/">CaribPR Wire</a></h1>
            </div>

		    <!-- VERY TOP NAVIGATION -->
            <ul id="topnav">
				<li class="current_page_item"><a href="http://caribpr.com/">Home</a></li>
                <li class="page_item page-item-1280"><a href="http://caribpr.com/submit-your-release/" title="Submit Your Release">Submit Your Release</a></li>
<li class="page_item page-item-1296"><a href="http://caribpr.com/news-room/" title="News Room">News Room</a></li>
<li class="page_item page-item-1298"><a href="http://caribpr.com/press-release-tips/" title="Press Release Tips">Press Release Tips</a></li>
<li class="page_item page-item-1300"><a href="http://caribpr.com/testimonials/" title="Testimonials">Testimonials</a></li>
<li class="page_item page-item-1305"><a href="http://caribpr.com/caribbean-community/" title="Caribbean Community">Caribbean Community</a></li>
<li class="page_item page-item-1303"><a href="http://caribpr.com/contact-us/" title="Contact Us">Contact Us</a></li>
			</ul>			
			
		    <!-- ADMIN NAVIGATION 
            <ul id="navAdmin">
                <li><a href="http://caribpr.com/wp-login.php?action=register">Register</a></li>                <li><a href="http://caribpr.com/wp-login.php">Log in</a></li>
                			</ul> -->

		    <!-- MAIN NAVIGATION -->
                        
            <!-- Alternative navigation -->
			
		<!--	<h2 style="position:absolute;left:250px; top: 55px;color:#cc0000;">The only Caribbean PR Wire Reaching Hundreds of Caribbean Media Houses, Websites, Blogs, And Opinion Leaders.</h2> -->
			
            <ul class="menu">
            	<li class="current_page_item"><a href="http://caribpr.com/">Home</a></li>
				            	<li><a href="/contact-us/">Contact Us</a></li>								

			<li class="nobackground" style="margin: -5px 6px 0 0">
				<form method="get" id="searchform" action="http://caribpr.com/">
	<div>
	<input class="search-field" type="text" onfocus="this.value=''" onblur="this.value='Search Releases...'" value="Search Releases..." name="s" id="s" />
	<input class="search-submit" type="submit" value="" />
	</div>
</form>
			</li>

			</ul>  
			
			<!-- / END MAIN NAVIGATION -->
            

            <!-- FEED 
            <a id="rss" href="http://caribpr.com/feed/" title="Syndicate this site using RSS">SUBSCRIBE TO <b>RSS</b></a>  -->

        </div>

        <div id="pageWrapper">
	<div id="sidebar" class="sidebar-left">
		<ul>
		
			
			<li class="page_item page-item-1273"><a href="http://caribpr.com/why-carib-pr-wire/" title="Why Carib PR Wire">Why Carib PR Wire</a></li>
<li class="page_item page-item-1280"><a href="http://caribpr.com/submit-your-release/" title="Submit Your Release">Submit Your Release</a></li>
<li class="page_item page-item-1312"><a href="http://caribpr.com/distribution/" title="Distribution">Distribution</a></li>
<li class="page_item page-item-1298"><a href="http://caribpr.com/press-release-tips/" title="Press Release Tips">Press Release Tips</a></li>
<li class="page_item page-item-1287"><a href="http://caribpr.com/our-rates/" title="Rate Sheet">Rate Sheet</a></li>
<li class="page_item page-item-1300"><a href="http://caribpr.com/testimonials/" title="Testimonials">Testimonials</a></li>
   



					</ul>
		<br/>
		<br/>
		<br/>
		<ul>
		
			<li class="page_item page-item-1321"><a href="http://caribpr.com/our-agency/" title="Our Agency">Our Agency</a></li>
<li class="page_item page-item-1305"><a href="http://caribpr.com/caribbean-community/" title="Caribbean Community">Caribbean Community</a></li>
<li class="page_item page-item-1430"><a href="http://caribpr.com/members-area/" title="Members Area">Members Area</a></li>
   
		
		</ul>
		
		<br/>
		<br/>
		
<div style="margin:10px; padding: 10px; background:#c7c7c7;"><a target="_blank" href="http://www.hardbeatcommunications.com"><img alt="hbcbanner" src="http://caribpr.com/uploads/2014/01/hbcbanner.jpeg"/></a></div>
<div style="margin:10px; padding: 10px; background:#c7c7c7;"><a target="_blank" href="http://www.newsamericasnow.com"><img alt="caribworldnews" src="http://caribpr.com/uploads/2014/01/caribworldnews.jpeg"/></a></div>
<div style="margin:10px; padding: 10px; background:#c7c7c7;"><a target="_blank" href="https://www.centsiblecalling.com/caribworldnews/"><img alt="calls" src="http://caribpr.com/uploads/2014/01/calls.jpeg"/></a></div>




		</div>

<div class="a2a_kit a2a_target addtoany_list" id="wpa2a_1"><a class="a2a_button_facebook" href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Facebook" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/facebook.png" width="16" height="16" alt="Facebook"/></a><a class="a2a_button_twitter" href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Twitter" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/twitter.png" width="16" height="16" alt="Twitter"/></a><a class="a2a_button_google_plus" href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Google+" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/google_plus.png" width="16" height="16" alt="Google+"/></a><a class="a2a_dd addtoany_share_save" href="http://www.addtoany.com/share_save" style="background:url(http://caribpr.com/wp-content/plugins/add-to-any/favicon.png) no-repeat scroll 4px 0px !important;padding:0 0 0 25px;display:inline-block;height:16px;vertical-align:middle">Share</a>
<script type="text/javascript"><!--
wpa2a.script_load();
//--></script>
</div>
<div id="content">


	
		<!--<div class="post-sep"></div> -->

        <div class="postWrapper">


			<div class="post" id="post-13184">
			
			<h2>For Immediate Release</h2>		
			
				<table class="tools" width="100%">
					<tbody class="act">
					
						<tr>
							<td class="licolumn">Title:</td>
							<td><b>Caribbeantales International Film Festival: The Legacy Edition</b></td>		
						</tr>
					</tbody>
				</table>
				
			
			<!--	<h1>Caribbeantales International Film Festival: The Legacy Edition</h1> -->
			
			<br/><br/>

				<div class="entry">
					<div class="addtoany_share_save_container addtoany_content_top"><div class="a2a_kit a2a_target addtoany_list" id="wpa2a_2"><a class="a2a_button_facebook" href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Facebook" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/facebook.png" width="16" height="16" alt="Facebook"/></a><a class="a2a_button_twitter" href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Twitter" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/twitter.png" width="16" height="16" alt="Twitter"/></a><a class="a2a_button_google_plus" href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Google+" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/google_plus.png" width="16" height="16" alt="Google+"/></a><a class="a2a_dd addtoany_share_save" href="http://www.addtoany.com/share_save" style="background:url(http://caribpr.com/wp-content/plugins/add-to-any/favicon.png) no-repeat scroll 4px 0px !important;padding:0 0 0 25px;display:inline-block;height:16px;vertical-align:middle">Share</a></div></div><p><strong><img class="size-full wp-image-13185 aligncenter" title="CTFF Legacy" src="http://caribpr.com/uploads/2017/07/CTFF-Legacy.png" alt="CTFF Legacy" width="238" height="302" />For Immediate Release</strong></p>
<p><strong> </strong></p>
<p><strong> </strong></p>
<p><strong><img class="alignleft size-full wp-image-13186" title="caribtalesjuly2017launc" src="http://caribpr.com/uploads/2017/07/caribtalesjuly2017launc.jpg" alt="caribtalesjuly2017launc" width="570" height="461" />CaribPR Wire, Toronto, Canada, Mon. July 17, 2017: </strong> On July 6, 2017, the CaribbeanTales International Film Festival (CTFF) held its Media Launch and Program Reveal, co-presented by the Consul General of Barbados at Toronto, with an evening of community and celebration. The packed event featured the Canadian Premiere screening of Barbadian film legend-in-the-making Shakirah Bourne&#8217;s latest fantasy feature film: <em>A Caribbean Dream. </em>And the international release of the trailer for Toronto-based filmmaker Sharon Lewis&#8217; fifteen-year labour of love: upcoming Afro-futurist feature film <em>Brown Girl Begins</em>.</p>
<p>“At twelve years old, CaribbeanTales has worked to create a brand for Caribbean Cinema, not divided by country, and inclusive of the Diaspora, that brings together our separate and collective legacies, our unique, distinctive and authentic stories,” said Frances-Anne Solomon, Executive Director, CTFF.</p>
<p>With fourteen (14) feature films and thirty (30) short films, from eighteen (18) countries, the twelfth annual CTFF promises to challenge viewers on the beauty and complexities of Caribbean legacy. This juried screening series will take place from September 6 to September 21, 2017 at The Royal Cinema, and at Cineplex Scotiabank Cinema.</p>
<p>The festival runs alongside the CaribbeanTales Incubator, which is a development and marketing hub for top filmmakers around the Caribbean and Diaspora.</p>
<p>“Through the Incubator, we’re pleased to support the growth of our Region’s film industry and simultaneously develop compelling creative content relevant for our Region, as well as a global audience – giving viewers at home and abroad top-notch Caribbean content,” said John Reid, CEO of Cable and Wireless / Flow, the lead sponsor of the CTFF and CTI.</p>
<p>The impact of this remarkable partnership is the exciting news that the three pilots emerged from CTI 2016, where funded by Flow and will be premiered at CTFF2017. With an amazing line-up of filmmakers for this year&#8217;s CTI, Flow has made the same commitment again.</p>
<p>Shakirah Bourne will also be representing Barbados at CTI 2017 with another fantasy project: <strong><em>Visit with the Obeah Woman</em></strong>. She will be joined by Karen Mafundikwa, with travel documentary series <strong><em>TRANScribe</em></strong> (Jamaica), Rick Elgood and Paul O Beale with comedic drama: <strong><em>The Agency</em></strong> (Jamaica), Roger Alexis with Santana spin-off <strong><em>Lexo Street</em></strong> (Trinidad and Tobago), Janine Fung’s comedy <strong><em>MIX UP </em></strong>(Trinidad and Tobago), Leticia Tonos with zombie thriller <strong><em>Inframundo </em></strong>(Dominican Republic), Louis Taylor and Altair Pflug Taylor with cynical reality show <strong><em>Spawn &amp; Geezer</em></strong> (Canada), Kareem Mortimer’s “crama-dy” <strong><em>Sully’s Manor</em></strong> (Bahamas), Cristobal Krusen with political drama <strong><em>Life or Death</em> </strong>(Belize), and Nicolas Cuellular and Nadege Robertson with environmental love story <strong><em>Fontizon &#8211; A Forest Grows in Haiti</em></strong> (Haiti).</p>
<p>These CTI filmmakers will be working over the next months to prepare for CaribbeanTales&#8217; crowning Industry Event: The Big Pitch at the TIFF Bell Lightbox on September 10, 2017 where they will pitch their projects to industry professionals. A limited number of tickets will be available for non-industry members wishing to attend.</p>
<p>Stay up to date with all CaribbeanTales activities by following the CTFF, and on Facebook, as well as the full organization on Twitter or Instagram.</p>
<div class="addtoany_share_save_container addtoany_content_bottom"><div class="a2a_kit a2a_target addtoany_list" id="wpa2a_3"><a class="a2a_button_facebook" href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Facebook" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/facebook.png" width="16" height="16" alt="Facebook"/></a><a class="a2a_button_twitter" href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Twitter" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/twitter.png" width="16" height="16" alt="Twitter"/></a><a class="a2a_button_google_plus" href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fcaribpr.com%2Fcaribbeantales-international-film-festival-the-legacy-edition%2F&amp;linkname=Caribbeantales%20International%20Film%20Festival%3A%20The%20Legacy%20Edition" title="Google+" rel="nofollow" target="_blank"><img src="http://caribpr.com/wp-content/plugins/add-to-any/icons/google_plus.png" width="16" height="16" alt="Google+"/></a><a class="a2a_dd addtoany_share_save" href="http://www.addtoany.com/share_save" style="background:url(http://caribpr.com/wp-content/plugins/add-to-any/favicon.png) no-repeat scroll 4px 0px !important;padding:0 0 0 25px;display:inline-block;height:16px;vertical-align:middle">Share</a></div></div>				</div>
			

		<br/>
		